CreativeMD

CreativeCore Mod 1.9, 1.8.9, 1.7.10

CreativeCore Mod 1.9, 1.8.9, 1.7.10 is a REQUIRED mod in order for any of the other mods to work in Minecraft 1.7.2 or later. It contains the core shared classes used by all CreativeMD‘s mods. If you don’t install it…

MinecraftLoader Mod 1.7.10, 1.7.2

MinecraftLoader Mod 1.7.10, 1.7.2 adds a loading bar while the game is loading mods. Installation: If your mod need Forge, you need download and install Minecraft Forge. Open minecraft.jar file at: C:\Users\(your computer name)\AppData\Roaming\.minecraft\bin or searching for “%appdata%” in your…