You are here: Home >> Minecraft Mods >> CompatLayer Mod 1.11, 1.10.2, 1.9.4 — Updated: November 26, 2016,

CompatLayer Mod 1.11, 1.10.2, 1.9.4

Minecraft Version: 1.11, 1.10.2, 1.9.4 | Developer: McJty | 67 views |

CompatLayer Mod 1.11, 1.10.2, 1.9.4 is a mod/library has some tools that can help to make mods binary compatible between 1.10 and 1.11. If you make sure you use the api in this mod correctly it is possible to make a mod jar that runs on both versions.

compatlayer-mod

A few things that you should do in addition to what this library does:

  • Make all resource names (lang files, model names, json files, texture files, …) lower case in your 1.10.2 version. Add a FMLMissingMapping event handler to take care old worlds load.
  • Mod id should be lowercase too.
  • Replace tileEntity.worldObj with tileEntity.getWorld().
  • Replace entityPlayer.worldObj with entityPlayer.getEntityWorld().

CompatLayer Mod Installation

  1. First you need download and install Minecraft Forge.
  2. Then download this Minecraft mod file at link below.
  3. Go to %appdata%. It can also be found by searching for “%appdata%” in your start menu.
  4. Go to .minecraft/mods folder.
  5. If the “mods” folder does’nt exist in your PC, you’ll need create one.
  6. Then drag and drop the downloaded .jar (or .zip) file into mods folder.
  7. Enjoy.

Download CompatLayer Mod

Share:


0 comment

New comment


Nice Theme

Nice Theme
WordPress Themes